This project is read-only.

Error with multi-friend-selector

Aug 8, 2008 at 11:16 AM

I'm creating an app in FBML and have added a simple request-form/multi-friend-selector for inviting other users but whenever I try to send an invitation I get an error in the Facebook javascript code saying "Button is not defined" and the invitation does not get sent.  Has anybody managed to get a friend selector working in FBML with Facebook.Net?

My code is as follows - I've stripped it down to make it as simple as possible but still get the error:

<fb:FacebookApplication ID="fbApplication" runat="server" Mode="Fbml" ApplicationName="Fuse-RJI-Test"
    EnableDebugging="true" />
<fb:fbml version="1.0">
        <fb:tab-item href='' title='Home'/>
        <fb:tab-item href='' title='Share' selected='true' />
    <fb:request-form action="share.aspx" method="POST" invite="true" type="Rob's test app" content="test" >
        <fb:multi-friend-selector showborder="false" actiontext="Invite your friends to use Rob's test app." exclude_ids="<%= FriendsWithApp %>" />



Aug 8, 2008 at 1:35 PM
This is how i do it:

<fb:request-form action="default.aspx" method="POST" invite="true" type="yourapp" content="yourtext <% = Server.HtmlEncode("<fb:req-choice url=\"\" label=\"OK\" />") %> " >
 <fb:multi-friend-selector max="20" showborder="false" actiontext="Invite your friends to blehbleh."> 
<fb:request-form-submit />

Hope it helps.

Aug 8, 2008 at 2:10 PM
Thanks for the reply.  Sadly it doesn't help.  I hoped it might be something to do with the fact that I didn't originally have the <fb:request-form-submit /> but using your code exactly (except for the app name in the URL) I still get the "button is not defined" javascript error.  I've stripped pretty much everything else out of my app.  Do you know if there might be anything I'm missing in the setup of the application?

It's driving me mad and at the moment pretty much making any other development on the app pointless.



Aug 8, 2008 at 11:40 PM
I'm not positive if the FBML-ness changes anything, but this is a known bug with Facebook.