This project is read-only.

HelloWorldFBML doesn't work? HTTP error code 404

Feb 7, 2008 at 2:40 AM
Has anyone been able to get the HelloWorldFBML example to actually work?

I run it without any code changes, and when I try to send my message I get:

Errors while loading page from application
Received HTTP error code 404 while loading http://76.xxx.xx.171/helloworldfbml/default.aspxDefault.aspx

My Callback URL is configured as: http://76.xxx.xx.171/helloworldfbml/default.aspx

Seems obvious to try to change the Callback URL to: http://76.xxx.xx.171/helloworldfbml/ right?

When I do that, I can't even hit the page at all, I get:

Errors while loading page from application
Received HTTP error code 405 while loading http://76.203.23.171/helloworldfbml/

I've tried both adding and removing a default page in IIS.

Nothing seems to work. I've spent at least 10 hours trying to figure this out in the Facebook Developer Toolkit (same issue) and now I'm having no luck with Facebook.NET. I MUST have something set up wrong somewhere.

Just knowing someone got this to work would be helpful. Maybe my IIS is hosed or something?

Thanks
Feb 7, 2008 at 4:38 AM
I got it!!!

Here's how I had to have things set up:

Callback URL: http://76.xxx.xx.171/helloworldfbml/

Side Nav URL: http://76.xxx.xx.171/helloworldfbml/default.aspx <------- This is the KEY change that took me 10 hours over 2 days to get around to trying!

This solved my problem. Man, in 10 years of IT, that's about the most frustrating issue I've ever seen. Seems obvious to me now.

Hope this saves someone else some pain.
Feb 7, 2008 at 7:11 AM
hi, have you tried iframe sample. i trying to work this for the past 10 days.

Getting nowhere .
Apr 9, 2009 at 11:47 AM
Edited Apr 9, 2009 at 12:08 PM
If we use iframe. we cannot use FBML for my application. So we need the solution in FBML setting
Sep 27, 2009 at 9:17 PM

What is the current setup page look like now.

The settings names have changed and I am having the same problem.

I know is the setup, but my CANVAS url has to be the website with the canvas.aspx page showing.

 

thanks.

Sep 27, 2009 at 9:26 PM

Nevermind. di the same thing you did, I just had to make my page the default on IIS. THANKS for you posting this did help me out.